MyException - 我的异常网
当前位置:我的异常网» C# » VS支持oracle11g吗解决方案

VS支持oracle11g吗解决方案

www.MyException.Cn  网友分享于:2013-02-20  浏览:21次
VS支持oracle11g吗
VS2008/2010支持oracle 11g吗?每次连接时都会报客户端需8.1以上版本。

------解决方案--------------------
VS2010/2012不能直接支持oracle 11g了

你可以参考oralce官方的"在 Oracle 数据库上使用 Microsoft Visual Studio 2010 构建 .NET 应用程序"

http://www.oracle.com/technetwork/cn/articles/dotnet/vs2010-oracle-dev-410461-zhs.html

------解决方案--------------------
http://bbs.csdn.net/topics/390351336

如果你不使用vs、.net framework中的oracle驱动,却要去安装什么oracle客户端、ODP.NET之类的,那么自然就会出现这个问题。


引用:
VS2010/2012不能直接支持oracle 11g了

你可以参考oralce官方的"在 Oracle 数据库上使用 Microsoft Visual Studio 2010 构建 .NET 应用程序"

http://www.oracle.com/technetwork/cn/articles/dotnet/vs2010-oracle-dev-410461-……


这能说明vs2010/2012不支持Oracle 11g?

假设原本是超市里卖猪肉,现在改为屠夫自己拉了一个车子站在街边卖猪肉了,你能以此为理由到处宣传超市就不卖猪肉了?
------解决方案--------------------
提示那个错误,多半是因为没有正确安装Oracle客户端导致的,比如你的系统是64位系统,却只有安装了32位客户端,而程序跑在64位模式下,找不到64位的Oracle驱动。
------解决方案--------------------
引用:
VS2008/2010支持oracle 11g吗?每次连接时都会报客户端需8.1以上版本。

目测你这个错误是因为你没装oracle客户端

文章评论

软件开发程序错误异常ExceptionCopyright © 2009-2015 MyException 版权所有