MyException - 我的异常网
当前位置:我的异常网» C# » 救命啊~~ 版本发布了,却遇到了可怕的有关问题!

救命啊~~ 版本发布了,却遇到了可怕的有关问题! 狂散分,求解

www.MyException.Cn  网友分享于:2013-12-27  浏览:10次
救命啊~~ 版本发布了,却遇到了可怕的问题!! 狂散分,求解!
用VS.NET2005出的版本,却只能在framework2.0框架下运行。有什么办法能解决在其他框架下运行的问题?~~~

------解决方案--------------------
如果是需要运行在早期的.net框架下,那就用Vs2003,或VS2002重新编一下你的程序,改掉编译不通过的地方,就可以保证你的程序在.net2.0也能运行,不过感觉也是个馊主意,因为:
1. 改动的工作量也许会很大
2. 即使改完了,没有时间测试,也只能祈祷程序运行时不会崩掉。

最好的做法,还是在你的程序安装包中加入.net2.0的安装程序吧,发现目标机器上没装.net2.0,你就给装上。免费装还不好啊? ^_^
------解决方案--------------------
VS.NET2005开发的东东,运行所要求的framework2只能是2.0或比2.0高的版本。
------解决方案--------------------
只能在更高的框架下运行
------解决方案--------------------
选择要安装的系统必备组件
在“解决方案资源管理器”中,选择部署项目。

在“项目”菜单上单击“属性”。

在“属性页”对话框中,展开“配置属性”节点,然后选择“生成”属性页。

单击“系统必备”按钮。

在“系统必备”对话框中,确保选中“创建用于安装系统必备组件的安装程序”复选框。

在“请选择要安装的系统必备组件”列表中,选中希望安装的系统必备组件,然后单击“确定”。

指定系统必备组件的下载位置
在“解决方案资源管理器”中,选择部署项目。

在“项目”菜单上单击“属性”。

在“属性页”对话框中,展开“配置属性”节点,然后选择“生成”属性页。

单击“系统必备”按钮。

在“系统必备”对话框中,选择一个位置:

如果要将系统必备组件的安装程序部署到供应商,请单击“从组件供应商的网站上下载系统必备组件”。

如果要将系统必备组件的安装程序部署到与应用程序安装程序相同的位置,请单击“从与我的应用程序相同的位置下载系统必备组件”。

如果要将系统必备组件的安装程序部署到另一个位置,请单击“从下列位置下载系统必备组件”,然后输入一个本地路径、URL 或文件共享位置

------解决方案--------------------
高版本在低版本里运行问题不大吧。

在IIS中新建一个应用程序池,然后选中你的 基于.net framework2.0的虚拟目录,点“属性”-》在“应用程序池” 中选择刚才新建的的应用程序池,点击“确定”。
试试看,不知道能不能解决你的问题
------解决方案--------------------
用VS.NET2005做的软件,只能在framework2.0框架或更高版本下运行,这是常识.接分
------解决方案--------------------
在“Web Setup Project”项目上点右键,选择“Properties”,在弹出的对话框中可以设置一些安装程序的属性。点击按钮“Prerequisites”,在弹出的对话框中选中“.NET Framework 2.0”和“Windows Installer 3.1”,选中“Download prerequisites from the same location as my application”。这样就可以把这些组件和应用程序打包在一起,安装的时候自动检测并安装了。如果需要部署的计算机如果没有打过最新的补丁的话,是没有“Windows Installer 3.1”的,如果没有这个组件,“.NET Framework 2.0”是不能安装的。
这种方法设置以后会在安装包里加入framework 2.0 和installer3.1,安装的时候直接安装。

文章评论

软件开发程序错误异常ExceptionCopyright © 2009-2015 MyException 版权所有