MyException - 我的异常网
当前位置:我的异常网» Oracle管理 » 使用数据泵导入,不兼容有关问题

使用数据泵导入,不兼容有关问题

www.MyException.Cn  网友分享于:2013-02-20  浏览:7次
使用数据泵导入,不兼容问题

语句:
Impdp scott/****@**** DIRECTORY=data_dump_dir DUMPFILE=****.dmp

我自己目前使用的是11g,请教一下如何在不更换自己的数据库的情况下导入数据呢?

------解决方案--------------------
低版本导出,高版本导入,默认就兼容
高版本导出,低版本导入,导出时可以加上version参数,指定具体的版本

------解决方案--------------------
•由Oracle高版本通过EXPDP导出的内容必须由Oracle等同版本来导入,否则就需要加版本号。如使用Oracle11.2.2的EXPDP导出的内容库要通过Oracle11.1.1导入会抛出版本不兼容,这里如果导出时加上VERSION=11指定大版本就可以了。
•由Oracle低版本通过EXPDP导出的数据库直接可被高版本向下兼容。

------解决方案--------------------
以我的理解:

LZ 用 11g 的 expdp [version=10.2.0.4.0] 导出dmp文件
然后用 10g 的impdp 导入dmp文件
应该是没有问题的

文章评论

软件开发程序错误异常ExceptionCopyright © 2009-2015 MyException 版权所有